<!DOCTYPE html>
<html>
<head>
  <!--[if IE]><![endif]-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://www.csnbayarea.com/sites/all/themes/custom/nbcsports/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="tp:EnableExternalController" content="true" />
<link rel="amphtml" href="http://www.csnbayarea.com/giants/giants-upton-jr-undergoes-surgery-torn-thumb-ligament?amp" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-57x57.png" rel="apple-touch-icon" sizes="57x57" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-57x57-precomposed.png" rel="apple-touch-icon-precomposed" sizes="57x57" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-72x72.png" rel="apple-touch-icon" sizes="72x72" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-72x72-precomposed.png" rel="apple-touch-icon-precomposed" sizes="72x72" />
<meta name="description" content="Veteran outfielder Melvin Upton Jr. will be out for at least two weeks after undergoing surgery Friday morning..." />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-114x114.png" rel="apple-touch-icon" sizes="114x114" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-114x114-precomposed.png" rel="apple-touch-icon-precomposed" sizes="114x114" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-120x120.png" rel="apple-touch-icon" sizes="120x120" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-120x120-precomposed.png" rel="apple-touch-icon-precomposed" sizes="120x120" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-144x144.png" rel="apple-touch-icon" sizes="144x144" />
<meta name="robots" content="follow, index" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-144x144-precomposed.png" rel="apple-touch-icon-precomposed" sizes="144x144" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-152x152-precomposed.png" rel="apple-touch-icon-precomposed" sizes="152x152" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-152x152.png" rel="apple-touch-icon" sizes="152x152" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-180x180.png" rel="apple-touch-icon" sizes="180x180" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-180x180-precomposed.png" rel="apple-touch-icon-precomposed" sizes="180x180" />
<meta name="rating" content="general" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="image_src" href="http://www.csnbayarea.com/sites/csnbayarea/files/2017/04/21/upton-ap.jpg" />
<link rel="canonical" href="http://www.csnbayarea.com/giants/giants-upton-jr-undergoes-surgery-torn-thumb-ligament" />
<link rel="shortlink" href="http://www.csnbayarea.com/node/213286" />
<meta property="og:site_name" content="NBCS Bay Area" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.csnbayarea.com/giants/giants-upton-jr-undergoes-surgery-torn-thumb-ligament" />
<meta property="og:title" content="Giants OF Upton Jr. undergoes surgery on torn thumb ligament" />
<meta property="og:description" content="Veteran outfielder Melvin Upton Jr. will be out for at least two weeks after undergoing surgery Friday morning..." />
<meta property="og:updated_time" content="2017-04-21T18:46:02-07:00" />
<meta property="og:image" content="http://www.csnbayarea.com/sites/csnbayarea/files/2017/04/21/upton-ap.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="http://www.csnbayarea.com/giants/giants-upton-jr-undergoes-surgery-torn-thumb-ligament" />
<meta name="twitter:title" content="Giants OF Upton Jr. undergoes surgery on torn thumb ligament" />
<meta name="twitter:description" content="Veteran outfielder Melvin Upton Jr. will be out for at least two weeks after undergoing surgery Friday morning..." />
<meta name="twitter:image" content="http://www.csnbayarea.com/sites/csnbayarea/files/2017/04/21/upton-ap.jpg" />
<meta property="article:published_time" content="2017-04-21T18:46:02-07:00" />
<meta property="article:modified_time" content="2017-04-21T18:46:02-07:00" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
  <meta name=viewport content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=no">
  <title>Giants OF Upton Jr. undergoes surgery on torn thumb ligament | NBCS Bay Area</title>
  <!-- Don't remove this. We are loading base file at first -->
  <style id="base-css">html{font-family:sans-serif;-ms-text-size-adjust:100%;-webkit-text-size-adjust:100%}body{margin:0}article,aside,details,figcaption,figure,footer,header,main,nav,section,summary{display:block}audio,canvas,progress,video{display:inline-block;vertical-align:baseline}audio:not([controls]){display:none;height:0}[hidden],template{display:none}a{background:transparent}a:active,a:hover{outline:0}abbr[title]{border-bottom:1px dotted}b,strong{font-weight:bold}dfn{font-style:italic}h1{font-size:2em;margin:0.67em 0}mark{background:#ff0;color:#000}small{font-size:80%}sub,sup{font-size:75%;line-height:0;position:relative;vertical-align:baseline}sup{top:-0.5em}sub{bottom:-0.25em}img{border:0}svg:not(:root){overflow:hidden}figure{margin:1em 40px}hr{box-sizing:content-box;height:0}pre{overflow:auto}code,kbd,pre,samp{font-family:monospace, monospace;font-size:1em}button,input,optgroup,select,textarea{color:inherit;font:inherit;margin:0}button{overflow:visible}button,select{text-transform:none}button,html input[type="button"],input[type="reset"],input[type="submit"]{-webkit-appearance:button;cursor:pointer}button[disabled],html input[disabled]{cursor:default}button::-moz-focus-inner,input::-moz-focus-inner{border:0;padding:0}input{line-height:normal}input[type="checkbox"],input[type="radio"]{box-sizing:border-box;padding:0}input[type="number"]::-webkit-inner-spin-button,input[type="number"]::-webkit-outer-spin-button{height:auto}input[type="search"]{-webkit-appearance:textfield;box-sizing:content-box}input[type="search"]::-webkit-search-cancel-button,input[type="search"]::-webkit-search-decoration{-webkit-appearance:none}fieldset{border:1px solid #c0c0c0;margin:0 2px;padding:0.35em 0.625em 0.75em}legend{border:0;padding:0}textarea{overflow:auto}optgroup{font-weight:bold}table{border-collapse:collapse;border-spacing:0}td,th{padding:0}html{font-family:Arial, Helvetica, sans-serif}a{text-decoration:none}h1,.alpha,h2,.beta,h3,.gamma,h4,.delta,h5,.epsilon,h6,.zeta{font-family:Arial, Helvetica, sans-serif;text-transform:uppercase}h1 a,h1 a:visited,.alpha a,.alpha a:visited,h2 a,h2 a:visited,.beta a,.beta a:visited,h3 a,h3 a:visited,.gamma a,.gamma a:visited,h4 a,h4 a:visited,.delta a,.delta a:visited,h5 a,h5 a:visited,.epsilon a,.epsilon a:visited,h6 a,h6 a:visited,.zeta a,.zeta a:visited{text-decoration:none}h1,.alpha{font-family:"BebasNeue", Arial, Helvetica, sans-serif;font-size:40px;font-size:2.5rem;font-weight:400}h2,.beta{font-size:34px;font-size:2.125rem}h3,.gamma{font-size:21px;font-size:1.312rem}h4,.delta{font-size:18px;font-size:1.125rem}h5,.epsilon{font-size:16px;font-size:1rem}h6,.zeta{font-size:16px;font-size:1rem}p{margin:0 0 1em}blockquote{padding:0 1.5em;font-style:italic}blockquote p{margin:0}q{font-style:italic}mark,.marker{padding:0.1em 0.5em;background:#666;color:#fff;font-size:12px;font-size:0.75rem;text-transform:capitalize}::-webkit-input-placeholder{color:#fff}:-moz-placeholder{color:#fff;opacity:1}::-moz-placeholder{color:#fff;opacity:1}:-ms-input-placeholder{color:#fff}img{max-width:100%;height:auto;vertical-align:top}.media-box iframe{width:100%;height:auto}@media (min-width: 1260px){.desktop-large_hidden {display: none !important;}.desktop-large_visible{display: block !important;}}@media (min-width: 1024px) and (max-width: 1260px){.desktop-small_hidden{display: none !important;}.desktop-small_visible{display: block !important;}}@media (min-width: 320px) and (max-width: 767px){.mobile_hidden{display:none !important}.mobile_visible{display:block !important}}@media (min-width: 768px) and (max-width: 1023px){.tablet_hidden{display:none !important}.tablet_visible{display:block !important}}</style>
  <link type="text/css" rel="stylesheet" href="//www.csnbayarea.com/sites/csnbayarea/files/advagg_css/css__jrqGI9sglxPUQhvSIq-kQBGexuo3F4pd3Jv1qwGbeNU__2_PvHKgOMcB9jFvtxgsCVahUI_B78k8mQrS5OQC3Zm0__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnbayarea.com/sites/csnbayarea/files/advagg_css/css__2s4LqmS7ajL_KL-83VOLNecXRUa0_NAbMWIwTIdvTts__YuoyovkbmHwxLlrZHLKnw5NoaojJrrSU-wvZaGcqXKg__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnbayarea.com/sites/csnbayarea/files/advagg_css/css__ZXyMdBl0buLF8vLGEao7S86RM2CjJz0jVh1zJsNr_Zg__SOEpjpUBnWWE2_JN2f--e5_YxWOtkCh9ZAupV88y-FA__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnbayarea.com/sites/csnbayarea/files/advagg_css/css__5P_0jIZnMez5K_C4iVqitqQABi6t0hv0ofNOh9qkdx8__RgsDjfBGPnQdIzJY9taMYyn3Us0vafGLz8pn4VmtwvE__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.css" media="all" />
  <!-- Script for catch errors on Js error testing.
       It should goes before Drupal scripts array and any placed script -->
  <script>
    window.jsErrors = [];
    window.onerror = function(errorMessage) {
      window.jsErrors[window.jsErrors.length] = errorMessage;
    };
  </script>
  <script type="text/javascript" src="//www.csnbayarea.com/sites/csnbayarea/files/advagg_js/js__dU859nniAHOO3ZZ49DZUXr5Frl9T3QSa81hYdDf9Uas__JILlNGib1Hz87izGwrCoeUVWHEurARtSrto0pJK-26Q__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var mpscall = {"site":"rsn-web","path":"\/node\/213286","title":"Giants OF Upton Jr. undergoes surgery on torn thumb ligament","qs":"cD15YTVuYmNzJm9jaWQ9eWFob28meXB0cj15YWhvbz9zcmM9cnNz","content_id":"node213286","is_content":"1","type":"article","cag":{"author":"NBC-Sports-Bay-Area-staff","league":"MLB","section":"Giants","sport":"Baseball","tags":"Melvin-Upton-Jr|MLB|San-Francisco-Giants|Stack-Giants|Stack-Homepage|Stack-Giants|Stack-Homepage","team":"Giants","field-videos":"1-on-1-with-GM-Bobby-Evans-What-Bumgarner-injury-means-for-Giants"},"pubdate":"1492825562"}
var mpsopts = {"host":"mps.nbcuni.com","updatecorrelator":"1"}
var mps=mps||{};mps._ext=mps._ext||{};mps._adsheld=[];mps._queue=mps._queue||{};mps._queue.gptloaded=mps._queue.gptloaded||[];mps.__timer=Date.now();mps.__intcode="v2"; "function"!=typeof mps.getAd&&(mps.getAd=function(a){if("string"!=typeof a)return!1;var b="mps-getad-"+a.replace(/\W/g,"");mps._ext&&mps._ext.loaded||(mps._queue.gptloaded.push(function(){"function"==typeof mps._gptfirst&&mps._gptfirst();mps.insertAd("#"+b,a)}),mps._adsheld.push(a));return'<div id="'+b+'" class="mps-wrapper" data-mps-fill-slot="'+a+'"></div>'});(function(){head=document.head||document.getElementsByTagName("head")[0];mpsload=document.createElement("script");mpsload.src="//"+mpsopts.host+"/fetch/ext/load-"+mpscall.site+".js?nowrite=2";mpsload.id="mps-load";head.insertBefore(mpsload,head.firstChild)})();
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnbayarea.com/sites/csnbayarea/files/advagg_js/js__lj8t3ZR9OqxjIdO80SOoTUeOBlfyvG2iv79lCDM3QBQ__V2hfJDBXK4gkwi4KglCyTp89c9iUvEm_w_q7gs3-ZFw__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnbayarea.com/sites/csnbayarea/files/advagg_js/js__ZPSNIc2V1mJcmCsS8dAa4wjhJEDPUDXiLclnt1wyQJo__RJ9xi9wU_oAnYHhFY0XWtFBkVimQ6UfUNThk7quaoZA__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.js" async="async"></script>
<script type="text/javascript" src="//www.csnbayarea.com/sites/csnbayarea/files/advagg_js/js___Weo722cMICqp_44WWk_lcjyIQB-yadh-caReRrGI18__O4A57Sv5pz88_XnltO_gB5wHXvKWgKesy_ZA-iNCclg__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.js" async="async"></script>
<script type="text/javascript" src="//www.csnbayarea.com/sites/csnbayarea/files/advagg_js/js__j_mvU6GjInKTuW3uzP34uzA_5OlaotUyiatneT2SiWY__97TX66XCItf69p6-4twvumMIpchbZVLDVdG7Ce3zN1A__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'), document.getElementsByTagName('script')[0], 'http://cdn.taboola.com/libtrc/nbcsports-csnbayarea/loader.js');
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnbayarea.com/sites/csnbayarea/files/advagg_js/js__UpIagL88__z0aKsv0IxjQ4mipVSe24kwfI5ue003iEU___WyM6b0R1KGOdVG5wfY5ByA_ESETPB9TpoBHvivcNU8__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.__gigyaConf = {"enabledProviders":"*","sessionExpiration":2000000,"connectWithoutLoginBehavior":"loginExistingUser"}
//--><!]]>
</script>
<script type="text/javascript" src="//cdn.gigya.com/JS/socialize.js?apikey=2__jd-172a6AyTd5GwWPv1y-QLHJEJ8VPjd0KfvUXsLLNGrDjWxyL9DNZKJqNvce7q&amp;lang=en"></script>
<script type="text/javascript" src="//www.csnbayarea.com/sites/csnbayarea/files/advagg_js/js__NRBPtqXMfbnJnF-PrIangoYFOAhOS15PVR831iTDPYc__neeA2WYzvW7iFDxEaMLmZeh0A_inBsJJmSp2FuF-9ks__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.js"></script>
<script type="text/javascript" src="//www.csnbayarea.com/sites/csnbayarea/files/advagg_js/js__vgkAU7ftKvruRwfVcgbGzRP4sejSp5trysC_1C5Rtbo__qZ94Wuw8nP9OidqrZTPVyh5pF2ogBAbTpvL9ZYpwd7I__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.js"></script>
<script type="text/javascript" src="//www.csnbayarea.com/sites/csnbayarea/files/advagg_js/js__BHbH70wS7-F90kHyP54oL4hqEmk1FqPhmrI9TPl8Tak__ml4144ZU23dDWLgm95iCVeMdpCa_uz8znrMUGpmoZN0__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.js"></script>
<script type="text/javascript">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</script>
</head>
<body class="html not-front not-logged-in page-node page-node- page-node-213286 node-type-article rsn-site rsn-site-csnbayarea has-two-sidebars" >
    
  <header id="nbcsports-fixed-header">

    <!-- start Primary Nav -->
    <nav id="nbcsports-primary-nav">
                  <a href="http://www.csnbayarea.com" id="home-page-link"></a>  <a href="http://www.csnbayarea.com/warriors" class="dynamic-nav-link" data-tid="256">Warriors</a>  <a href="http://www.csnbayarea.com/kings" class="dynamic-nav-link" data-tid="216">Kings</a>  <a href="http://www.csnbayarea.com/49ers" class="dynamic-nav-link" data-tid="181">49ers</a>  <a href="http://www.csnbayarea.com/raiders" class="dynamic-nav-link" data-tid="236">Raiders</a>  <a href="http://www.csnbayarea.com/sharks" class="dynamic-nav-link" data-tid="251">Sharks</a>  <a href="http://www.csnbayarea.com/giants" class="dynamic-nav-link" data-tid="201">Giants</a>  <a href="http://www.csnbayarea.com/athletics" class="dynamic-nav-link" data-tid="196">Athletics</a>  <a href="http://www.csnbayarea.com/earthquakes" class="dynamic-nav-link" data-tid="231">Quakes</a>  <a href="http://www.csnbayarea.com/video" class="dynamic-nav-link" data-tid="126">Video</a>
<span id="more-nav-btn" class="no-select no-more-links" unselectable="on" tabindex="0">MORE</span>
    </nav>
    <!-- end Primary Nav -->

    <!-- start More Nav -->
    <nav id="more-nav" class="no-more-links">
    </nav>
    <!-- end More Nav -->

    <!-- start Secondary Nav -->
    <nav id="nbcsports-secondary-nav">
        
<div class="nbcsports-secondary-nav__wrapper">

        <a href="http://stats.csnbayarea.com/gz/baseball/mlb/team/250">In-Game Live</a>        <a href="http://www.csnbayarea.com/video">Video</a>        <a href="http://www.csnbayarea.com/author/alex-pavlovic">Alex Pavlovic</a>        <a href="http://www.csnbayarea.com/page/giants-insider-podcast-alex-pavlovic">Insider Podcast</a>        <a href="http://stats.csnbayarea.com/mlb/teamreports.asp?tm=26&amp;report=schedule">Schedule</a>        <a href="http://stats.csnbayarea.com/mlb/standings.asp">Standings</a>        <a href="http://stats.csnbayarea.com/mlb/teamreports.asp?tm=26&amp;report=stats">Stats</a>        <a href="https://www.stubhub.com/san-francisco-giants-tickets/performer/197/?gcid=chAFF-_-geoUS-_-genMLB-_-dt170602-_-cmpCSNBay_MLB-_-partNBCSports">Tickets</a>        <a href="http://www.comcastsportsnet.com" class="rsn-local-nav">CSN</a>        <a href="http://www.rotoworld.com" class="rotoworld-nav">Rotoworld</a>        <a href="http://www.golfchannel.com" class="golf-channel-nav">Golf Channel</a>  
  <div id="nbcsports-search-box">
    <form action="http://www.csnbayarea.com/search" class="search-form" method="get" autocomplete="off">
      <span class="icon"></span>
      <label>Search</label>
      <input type="search" name="search_api_views_fulltext" id="nbcsports-search" placeholder="Search NBC Sports Bay Area" tabindex="0"/>
    </form>
  </div>

</div>
    </nav>
    <!-- end Secondary Nav -->

  </header>
  <!-- end #nbcsports-fixed-header -->

  <div id="wrapper">
    <div id="outer">
      <!-- Start leaderboard -->
      <div id="nbcsports-leaderboard">
                    <div class="region region-top-region">
    <div id="block-bean-dx-agency-twitter-pixel" class="block block-bean block-bean-custom-block block-type-custom-block block-type-custom-block-single">

    
  <div class="content">
    <div class="entity entity-bean bean-custom-block clearfix">

  <div class="content">
    <div class="field field-name-field-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><!-- Twitter universal website tag code -->
<script>
!function(e,t,n,s,u,a){e.twq||(s=e.twq=function(){s.exe?s.exe.apply(s,arguments):s.queue.push(arguments);
},s.version='1.1',s.queue=[],u=t.createElement(n),u.async=!0,u.src='//static.ads-twitter.com/uwt.js',
a=t.getElementsByTagName(n)[0],a.parentNode.insertBefore(u,a))}(window,document,'script');
// Insert Twitter Pixel ID and Standard Event data below
twq('init','nvx99');
twq('track','PageView');
</script>
<!-- End Twitter universal website tag code --></div></div></div>  </div>
</div>
  </div>
</div>
<div id="block-mps-topbanner" class="block block-mps">

    
  <div class="content">
    <div id="topbanner"><script>typeof(mps)=='object' && typeof(mps.getAd)=='function' && document.write(mps.getAd('topbanner'));</script></div>  </div>
</div>
  </div>
              </div>
      <!-- End leaderboard -->

      <!-- Start scoreboard -->
              <div id="nbcsports-scoreboard">
            <div class="region region-scoreboard">
    <div class="scoreboard with_ad">
  <iframe id="scoreboard-ticker" src="http://csnbayarea.stats.com/score_ticker/index.html?sports=LOCAL%7CMLB%7CNBA%7CNFL%7CNHL%7CMLS%7CCFB%7CCBK%7CGOLF%7CNASCAR%7CFORM1%7CEPL"></iframe>
</div>
<div id="block-mps-scorelogo" class="block block-mps">

    
  <div class="content">
    <div id="scorelogo"><script>typeof(mps)=='object' && typeof(mps.getAd)=='function' && document.write(mps.getAd('scorelogo'));</script></div>  </div>
</div>
  </div>
        </div>
            <!-- Start scoreboard -->

      <!-- Start content wrapper -->
      <div id="nbcsports-content-wrapper">

        <aside id="nbcsports-live-extra-widget">
                        <div class="region region-left-rail">
    <div id="block-bean-giants-highlights-vod" class="block block-bean">

    
  <div class="content">
    <div  class="vod-content">
  <a href="http://www.csnbayarea.com/live" class="link link_type-block"><div class=""></div></a>
  <header class="title vod-content__title">
    <span class="title-text">Latest Videos</span>
  </header>
  <div class="vod-content__scrollbox">
    <div class="vod-content__events" id="vod-touch-events">
      <div class="events-list vod-content__events-list">
        <ul class="list events-list__list">
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-213331" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnbayarea.com/video/kruk-kuip-frustration-continues-rough-day-giants">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/421krukkuip.jpg?itok=-udUnGfJ&amp;timestamp=1492835881 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/421krukkuip.jpg?itok=br4fNfrb&amp;timestamp=1492835881 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/421krukkuip.jpg?itok=-udUnGfJ&amp;timestamp=1492835881 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/421krukkuip.jpg?itok=br4fNfrb&amp;timestamp=1492835881 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/421krukkuip.jpg?itok=-udUnGfJ&amp;timestamp=1492835881 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/421krukkuip.jpg?itok=br4fNfrb&amp;timestamp=1492835881 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/421krukkuip.jpg?itok=-udUnGfJ&amp;timestamp=1492835881 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/421krukkuip.jpg?itok=br4fNfrb&amp;timestamp=1492835881 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/421krukkuip.jpg?itok=-udUnGfJ&amp;timestamp=1492835881" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:09</div>
                  </span>
        <span class="media-thumb__title">Kruk &amp; Kuip: Frustration continues in rough day for Giants</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-213301" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnbayarea.com/video/drive-game-flashback-pences-457-foot-blast-coors-field">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/42117gdrive.jpg?itok=MUgeGS2Y&amp;timestamp=1492828383 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/42117gdrive.jpg?itok=03sRrfJz&amp;timestamp=1492828383 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/42117gdrive.jpg?itok=MUgeGS2Y&amp;timestamp=1492828383 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/42117gdrive.jpg?itok=03sRrfJz&amp;timestamp=1492828383 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/42117gdrive.jpg?itok=MUgeGS2Y&amp;timestamp=1492828383 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/42117gdrive.jpg?itok=03sRrfJz&amp;timestamp=1492828383 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/42117gdrive.jpg?itok=MUgeGS2Y&amp;timestamp=1492828383 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/42117gdrive.jpg?itok=03sRrfJz&amp;timestamp=1492828383 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/42117gdrive.jpg?itok=MUgeGS2Y&amp;timestamp=1492828383" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">0:26</div>
                  </span>
        <span class="media-thumb__title">Drive of the Game: Flashback to Pence&#039;s 457-foot blast</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-213251" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnbayarea.com/video/pavlovic-provides-giants-mindset-after-learning-bumgarners-injury">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/bochy-bum.jpg?itok=foUK3eSa&amp;timestamp=1492821122 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/bochy-bum.jpg?itok=Bw0gfMKR&amp;timestamp=1492821122 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/bochy-bum.jpg?itok=foUK3eSa&amp;timestamp=1492821122 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/bochy-bum.jpg?itok=Bw0gfMKR&amp;timestamp=1492821122 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/bochy-bum.jpg?itok=foUK3eSa&amp;timestamp=1492821122 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/bochy-bum.jpg?itok=Bw0gfMKR&amp;timestamp=1492821122 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/bochy-bum.jpg?itok=foUK3eSa&amp;timestamp=1492821122 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/bochy-bum.jpg?itok=Bw0gfMKR&amp;timestamp=1492821122 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/bochy-bum.jpg?itok=foUK3eSa&amp;timestamp=1492821122" alt="bochy-bum.jpg" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:52</div>
                  </span>
        <span class="media-thumb__title">Pavlovic provides Giants&#039; mindset after Bumgarner&#039;s injury</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-213246" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnbayarea.com/video/1-1-gm-bobby-evans-what-bumgarner-injury-means-giants">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421evanskoz.jpg?itok=6RkpvXwG&amp;timestamp=1492819681 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421evanskoz.jpg?itok=lWgW4Wl3&amp;timestamp=1492819681 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421evanskoz.jpg?itok=6RkpvXwG&amp;timestamp=1492819681 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421evanskoz.jpg?itok=lWgW4Wl3&amp;timestamp=1492819681 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421evanskoz.jpg?itok=6RkpvXwG&amp;timestamp=1492819681 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421evanskoz.jpg?itok=lWgW4Wl3&amp;timestamp=1492819681 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421evanskoz.jpg?itok=6RkpvXwG&amp;timestamp=1492819681 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421evanskoz.jpg?itok=lWgW4Wl3&amp;timestamp=1492819681 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421evanskoz.jpg?itok=6RkpvXwG&amp;timestamp=1492819681" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">4:03</div>
                  </span>
        <span class="media-thumb__title">1-on-1 with Evans: What Bumgarner injury means for Giants</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-213226" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnbayarea.com/video/bochy-reacts-bumgarner-injury-tells-conversation-giants-ace">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421bochybumgarner.jpg?itok=Z_WfP66k&amp;timestamp=1492818799 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421bochybumgarner.jpg?itok=-VAmtPrx&amp;timestamp=1492818799 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421bochybumgarner.jpg?itok=Z_WfP66k&amp;timestamp=1492818799 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421bochybumgarner.jpg?itok=-VAmtPrx&amp;timestamp=1492818799 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421bochybumgarner.jpg?itok=Z_WfP66k&amp;timestamp=1492818799 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421bochybumgarner.jpg?itok=-VAmtPrx&amp;timestamp=1492818799 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421bochybumgarner.jpg?itok=Z_WfP66k&amp;timestamp=1492818799 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421bochybumgarner.jpg?itok=-VAmtPrx&amp;timestamp=1492818799 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421bochybumgarner.jpg?itok=Z_WfP66k&amp;timestamp=1492818799" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">3:15</div>
                  </span>
        <span class="media-thumb__title">Bochy reacts to Bumgarner injury; conversation with ace</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-213161" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnbayarea.com/video/bumgarner-dl-after-dirt-bike-accident-gut-punch-giants">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421bumgarnernewsroom.jpg?itok=xt2ZFeiL&amp;timestamp=1492812183 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421bumgarnernewsroom.jpg?itok=tfeLvSfO&amp;timestamp=1492812183 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421bumgarnernewsroom.jpg?itok=xt2ZFeiL&amp;timestamp=1492812183 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421bumgarnernewsroom.jpg?itok=tfeLvSfO&amp;timestamp=1492812183 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421bumgarnernewsroom.jpg?itok=xt2ZFeiL&amp;timestamp=1492812183 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421bumgarnernewsroom.jpg?itok=tfeLvSfO&amp;timestamp=1492812183 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421bumgarnernewsroom.jpg?itok=xt2ZFeiL&amp;timestamp=1492812183 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/21/0421bumgarnernewsroom.jpg?itok=tfeLvSfO&amp;timestamp=1492812183 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/21/0421bumgarnernewsroom.jpg?itok=xt2ZFeiL&amp;timestamp=1492812183" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">4:54</div>
                  </span>
        <span class="media-thumb__title">Bumgarner on DL after bike accident a gut punch to Giants</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-212506" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnbayarea.com/video/bumgarner-you-have-pitch-more-careful-less-runs-offense">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/19/41917bumgarner.jpg?itok=Zx2DXX7d&amp;timestamp=1492661883 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/19/41917bumgarner.jpg?itok=WsYY_j5D&amp;timestamp=1492661883 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/19/41917bumgarner.jpg?itok=Zx2DXX7d&amp;timestamp=1492661883 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/19/41917bumgarner.jpg?itok=WsYY_j5D&amp;timestamp=1492661883 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/19/41917bumgarner.jpg?itok=Zx2DXX7d&amp;timestamp=1492661883 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/19/41917bumgarner.jpg?itok=WsYY_j5D&amp;timestamp=1492661883 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/19/41917bumgarner.jpg?itok=Zx2DXX7d&amp;timestamp=1492661883 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/19/41917bumgarner.jpg?itok=WsYY_j5D&amp;timestamp=1492661883 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/19/41917bumgarner.jpg?itok=Zx2DXX7d&amp;timestamp=1492661883" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:07</div>
                  </span>
        <span class="media-thumb__title">Bumgarner: You have to pitch more careful with less runs</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-212666" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnbayarea.com/video/giants-morning-minute-no-help-bumgarner-kansas-city">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/20/giantsmorningmin0419.jpg?itok=hL8S5Cp5&amp;timestamp=1492704798 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/20/giantsmorningmin0419.jpg?itok=LqzWtUZM&amp;timestamp=1492704798 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/20/giantsmorningmin0419.jpg?itok=hL8S5Cp5&amp;timestamp=1492704798 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/20/giantsmorningmin0419.jpg?itok=LqzWtUZM&amp;timestamp=1492704798 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/20/giantsmorningmin0419.jpg?itok=hL8S5Cp5&amp;timestamp=1492704798 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/20/giantsmorningmin0419.jpg?itok=LqzWtUZM&amp;timestamp=1492704798 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/20/giantsmorningmin0419.jpg?itok=hL8S5Cp5&amp;timestamp=1492704798 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_2x_/public/2017/04/20/giantsmorningmin0419.jpg?itok=LqzWtUZM&amp;timestamp=1492704798 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_6__desktop_large_/public/2017/04/20/giantsmorningmin0419.jpg?itok=hL8S5Cp5&amp;timestamp=1492704798" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:35</div>
                  </span>
        <span class="media-thumb__title">Giants Morning Minute: No help for Bumgarner in Kansas City</span>
      </a>
          </div>
  </div>
  </li>
                  </ul>
      </div>
    </div>
  </div>
  <footer class="vod-content__footer"></footer>
</div>
  </div>
</div>
  </div>
                  </aside>

        <!-- Start main content -->
        <div id="nbcsports-main" class="clearfix">

                      <div class="tabs">
                          </div>
          
          
                      <div id="nbcsports-content-header" class="content-header content-header_full-width">
                <div class="region region-header">
    <div id="block-nbcs-article-nbcs-article-subscription-bar" class="block block-nbcs-article">

    
  <div class="content">
    
<header id="article-nav">
      <div id="article-social-nav">
      <a href="http://www.csnbayarea.com/giants" class="blog-name">Giants</a>      <span class="blog-social-buttons">
                <span class="social-button-text"></span>
        <span class="blog-social-button-container">
                      <a href="https://www.facebook.com/NBCSAuthentic" class="genericon genericon-facebook" target="_blank"></a>                      <a href="/rss/section/Giants" class="genericon genericon-feed" target="_blank"></a>                      <a href="/alerts" class="genericon genericon-phone" target="_blank"></a>                      <a href="http://email.comcastsportsnet.com/csn/prefne.do" class="genericon genericon-mail" target="_blank"></a>                      <a href="https://twitter.com/csngiants" class="genericon genericon-twitter" target="_blank"></a>                  </span>
              </span>
    </div>
    <!-- #article-social-nav -->
</header>  </div>
</div>
  </div>
            </div>
          
          <div class="main-layout">
            <div class="layout_full-minus-right layout_first dynamic-lede">
              <div class="content-inner">
                                              </div>
            </div>

            <div class="layout_full-minus-right layout_second dynamic-lede">
                <div class="content-inner">
                    <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div class="articles--vod-player-fixed-container"></div>
<div class="articles__wrapper articles__node" data-taxonomy-term="201" data-vocabulary="6" data-active="213286">
  <div class="articles">
    
<article id="post-213286" class="article-module nbcs-article">
    <div class="article-midbanner" id="midbanner-213286"></div>
  <span id='chrome-data-post-213286' class="hidden" data-chrome='{"league":"mlb","sport":"baseball","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Giants OF Upton Jr. undergoes surgery on torn thumb ligament    </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-213286"
         href="http://www.csnbayarea.com/video/1-1-gm-bobby-evans-what-bumgarner-injury-means-giants"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/bayarea_article/select/media/VhyLNAcduHt6?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/0421evanskoz.jpg?itok=-lBsdDVs" width="656" height="369" alt="0421evanskoz.jpg" title="1-on-1 with GM Bobby Evans: What Bumgarner injury means for Giants" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Giants OF Upton Jr. undergoes surgery on torn thumb ligament    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/nbc-sports-bay-area-staff">NBC Sports Bay Area staff</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnbayarea.com/giants/giants-upton-jr-undergoes-surgery-torn-thumb-ligament"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">April 21, 2017 6:40 PM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-213286" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-213286" id="comments-link-213286" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-213286">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
                        </div>
    <p>The Giants completed a minor league deal with veteran outfielder Melvin Upton Jr. <a href="http://www.csnbayarea.com/giants/giants-finalize-minor-league-deal-melvin-upton-jr"><strong>on April 12</strong></a>. Just over a week later, Upton will be on the shelf for multiple weeks.&nbsp;</p>
<p>Upton, 32, underwent surgery Friday morning for a torn ligament in his thumb. The injury occured in extended spring training.&nbsp;</p>
<p>Max Wildstein of HardballScoop.com was <a href="https://twitter.com/MaxWildstein/status/855531088894205953" target="_blank">first to report the news</a>. Andrew Baggarly of the Bay Area News Group <a href="https://twitter.com/extrabaggs/status/855585014804873221" target="_blank">confirmed the report</a> through GM Bobby Evans.</p>
<p>Upton is expected to miss a minimum of eight weeks.</p>
<p>In 2016, Upton hit 20 home runs and stole 27&nbsp;bases in 149 games between the Padres and Blue Jays.&nbsp;</p>
<p>Upton has belted 164 home runs and stolen 300 bases in his 12-year career.&nbsp;</p>
<iframe style="border: none; margin:0px; width:100%; height:250px;" src="https://www.stanza.co/@mlb-giants?embed=true&banner=true&site=comcastsportsnet"></iframe> 
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/melvin-upton-jr" rel="tag">Melvin Upton Jr</a>, <a href="/tags/mlb" rel="tag">MLB</a>, <a href="/tags/san-francisco-giants" rel="tag">San Francisco Giants</a></span>
        <div class="comments-container">
              <div id="respond-213286">
          <div id="213286" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-213286"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-213286"></div>
    <div id="taboola-container-text-links-post-213286"></div>
  </footer>
  <!-- .entry-footer -->
</article>

<article id="post-213326" class="article-module nbcs-article">
    <div class="article-midbanner" id="midbanner-213326"></div>
  <span id='chrome-data-post-213326' class="hidden" data-chrome='{"league":"","sport":"baseball","sponsor":"alexpavlovic"}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Ball lost in lights, failure to execute late haunt Giants in loss to Rockies    </h2>
          <div class="article-chromedheader"></div>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-213326"
         href="http://www.csnbayarea.com/video/kruk-kuip-frustration-continues-rough-day-giants"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/bayarea_article/select/media/xewHEy_D6YPp?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/421krukkuip.jpg?itok=rY5f80AM" width="656" height="369" alt="421krukkuip.jpg" title="Kruk &amp; Kuip: Frustration continues in rough day for Giants" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Ball lost in lights, failure to execute late haunt Giants in loss to Rockies    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/alex-pavlovic">Alex Pavlovic</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnbayarea.com/giants/ball-lost-lights-failure-execute-late-haunt-giants-loss-rockies"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">April 21, 2017 9:29 PM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-213326" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-213326" id="comments-link-213326" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-213326">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
              <div  class="media-card media-card_size-single media-card_type-headlines media-card_branded">
      <div class="media-card__title media-card__title_branded">
      <a class="branded-header-single link" href="http://www.csnbayarea.com/author/alex-pavlovic" >
            <div class="branded-header-single-col" >
                  <picture  class="branded-image-1-column">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/branded_1_column__desktop_large_/public/2017/02/21/pavlovic-header-1col-aaa.jpg?itok=46qyKnT7&amp;timestamp=1487716293 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/branded_1_column__desktop_large_2x_/public/2017/02/21/pavlovic-header-1col-aaa.jpg?itok=CrXG0nHO&amp;timestamp=1487716293 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/branded_1_column__desktop_large_/public/2017/02/21/pavlovic-header-1col-aaa.jpg?itok=46qyKnT7&amp;timestamp=1487716293 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/branded_1_column__desktop_large_2x_/public/2017/02/21/pavlovic-header-1col-aaa.jpg?itok=CrXG0nHO&amp;timestamp=1487716293 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/branded_1_column__desktop_large_/public/2017/02/21/pavlovic-header-1col-aaa.jpg?itok=46qyKnT7&amp;timestamp=1487716293 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/branded_1_column__desktop_large_2x_/public/2017/02/21/pavlovic-header-1col-aaa.jpg?itok=CrXG0nHO&amp;timestamp=1487716293 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/branded_1_column__desktop_large_/public/2017/02/21/pavlovic-header-1col-aaa.jpg?itok=46qyKnT7&amp;timestamp=1487716293 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/branded_1_column__desktop_large_2x_/public/2017/02/21/pavlovic-header-1col-aaa.jpg?itok=CrXG0nHO&amp;timestamp=1487716293 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  class="branded-image-1-column" src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/branded_1_column__desktop_large_/public/2017/02/21/pavlovic-header-1col-aaa.jpg?itok=46qyKnT7&amp;timestamp=1487716293" alt="" title="" />
</picture>              </div>
    
    
      </a>
  </div>
    <div class="media-card__inner">
          <div  class="story story_count-1">

      <div class="story__image">
              <a id="media-card-link-213326" class="link" href="/giants/ball-lost-lights-failure-execute-late-haunt-giants-loss-rockies">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/blackmon-hr-ap.jpg?itok=JztLFGAT&amp;timestamp=1492836054 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/blackmon-hr-ap.jpg?itok=-PFe3EQb&amp;timestamp=1492836054 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/blackmon-hr-ap.jpg?itok=JztLFGAT&amp;timestamp=1492836054 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/blackmon-hr-ap.jpg?itok=-PFe3EQb&amp;timestamp=1492836054 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/blackmon-hr-ap.jpg?itok=JztLFGAT&amp;timestamp=1492836054 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/blackmon-hr-ap.jpg?itok=-PFe3EQb&amp;timestamp=1492836054 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/blackmon-hr-ap.jpg?itok=JztLFGAT&amp;timestamp=1492836054 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/blackmon-hr-ap.jpg?itok=-PFe3EQb&amp;timestamp=1492836054 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/blackmon-hr-ap.jpg?itok=JztLFGAT&amp;timestamp=1492836054" alt="blackmon-hr-ap.jpg" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-213326" class="link" href="/giants/ball-lost-lights-failure-execute-late-haunt-giants-loss-rockies">
      <span>Ball lost in lights, failure to execute late haunt Giants in loss to Rockie...</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-2">

      <div class="story__image">
              <a id="media-card-link-213311" class="link" href="/giants/instant-replay-giants-offense-comes-alive-cueto-allows-six-rockies">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/giants-ir-us.jpg?itok=mxRDnJVt&amp;timestamp=1492831329 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/giants-ir-us.jpg?itok=oUQg7bt2&amp;timestamp=1492831329 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/giants-ir-us.jpg?itok=mxRDnJVt&amp;timestamp=1492831329 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/giants-ir-us.jpg?itok=oUQg7bt2&amp;timestamp=1492831329 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/giants-ir-us.jpg?itok=mxRDnJVt&amp;timestamp=1492831329 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/giants-ir-us.jpg?itok=oUQg7bt2&amp;timestamp=1492831329 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/giants-ir-us.jpg?itok=mxRDnJVt&amp;timestamp=1492831329 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/giants-ir-us.jpg?itok=oUQg7bt2&amp;timestamp=1492831329 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/giants-ir-us.jpg?itok=mxRDnJVt&amp;timestamp=1492831329" alt="giants-ir-us.jpg" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-213311" class="link" href="/giants/instant-replay-giants-offense-comes-alive-cueto-allows-six-rockies">
      <span>Instant Replay: Giants&#039; offense comes alive, but Cueto allows six to R...</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-3">

      <div class="story__image">
              <a id="media-card-link-213231" class="link" href="/giants/giants-notes-bochy-returns-ready-roll-after-minor-heart-procedure">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/bochy-blach-us.jpg?itok=DisH4NBc&amp;timestamp=1492819858 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/bochy-blach-us.jpg?itok=mhGYF1th&amp;timestamp=1492819858 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/bochy-blach-us.jpg?itok=DisH4NBc&amp;timestamp=1492819858 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/bochy-blach-us.jpg?itok=mhGYF1th&amp;timestamp=1492819858 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/bochy-blach-us.jpg?itok=DisH4NBc&amp;timestamp=1492819858 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/bochy-blach-us.jpg?itok=mhGYF1th&amp;timestamp=1492819858 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/bochy-blach-us.jpg?itok=DisH4NBc&amp;timestamp=1492819858 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/bochy-blach-us.jpg?itok=mhGYF1th&amp;timestamp=1492819858 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/bochy-blach-us.jpg?itok=DisH4NBc&amp;timestamp=1492819858" alt="bochy-blach-us.jpg" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-213231" class="link" href="/giants/giants-notes-bochy-returns-ready-roll-after-minor-heart-procedure">
      <span>Giants notes: Bochy returns, &#039;ready to roll&#039; after minor heart pr...</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-4">

      <div class="story__image">
              <a id="media-card-link-213136" class="link" href="/giants/giants-place-madison-bumgarner-disabled-list-after-dirt-bike-accident">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/madison-disabled-list_1.jpg?itok=rT-FJBWg&amp;timestamp=1492807482 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/madison-disabled-list_1.jpg?itok=QcJ5rO5E&amp;timestamp=1492807482 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/madison-disabled-list_1.jpg?itok=rT-FJBWg&amp;timestamp=1492807482 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/madison-disabled-list_1.jpg?itok=QcJ5rO5E&amp;timestamp=1492807482 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/madison-disabled-list_1.jpg?itok=rT-FJBWg&amp;timestamp=1492807482 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/madison-disabled-list_1.jpg?itok=QcJ5rO5E&amp;timestamp=1492807482 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/madison-disabled-list_1.jpg?itok=rT-FJBWg&amp;timestamp=1492807482 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/21/madison-disabled-list_1.jpg?itok=QcJ5rO5E&amp;timestamp=1492807482 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/21/madison-disabled-list_1.jpg?itok=rT-FJBWg&amp;timestamp=1492807482" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-213136" class="link" href="/giants/giants-place-madison-bumgarner-disabled-list-after-dirt-bike-accident">
      <span>Giants place Madison Bumgarner on disabled list after dirt bike accident</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-5">

      <div class="story__image">
              <a id="media-card-link-212761" class="link" href="http://www.csnbayarea.com/page/giants-insider-podcast-alex-pavlovic">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/20/giants_insider_podcast.jpg?itok=8Tn1BpgF&amp;timestamp=1492730094 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/20/giants_insider_podcast.jpg?itok=6kiWXTSA&amp;timestamp=1492730094 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/20/giants_insider_podcast.jpg?itok=8Tn1BpgF&amp;timestamp=1492730094 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/20/giants_insider_podcast.jpg?itok=6kiWXTSA&amp;timestamp=1492730094 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/20/giants_insider_podcast.jpg?itok=8Tn1BpgF&amp;timestamp=1492730094 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/20/giants_insider_podcast.jpg?itok=6kiWXTSA&amp;timestamp=1492730094 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/20/giants_insider_podcast.jpg?itok=8Tn1BpgF&amp;timestamp=1492730094 1x, http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_2x_/public/2017/04/20/giants_insider_podcast.jpg?itok=6kiWXTSA&amp;timestamp=1492730094 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnbayarea.com/sites/csnbayarea/files/styles/half_4__desktop_large_/public/2017/04/20/giants_insider_podcast.jpg?itok=8Tn1BpgF&amp;timestamp=1492730094" alt="giants_insider_podcast.jpg" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-212761" class="link" href="http://www.csnbayarea.com/page/giants-insider-podcast-alex-pavlovic">
      <span>The Giants Insider Podcast: Eno Sarris</span>
    </a>
  </h3>

  </div>
      </div>
</div>
          </div>
    <p>DENVER — There were a lot of plays that decided Friday’s game, including a Johnny Cueto pitch that sailed over the the right field wall for a grand slam and a liner to right that got away from Hunter Pence and turned into an inside-the-park homer. But the play that seemed to stick with manager Bruce Bochy the most was one the Giants didn’t make at the plate.&nbsp;</p>
<p>With two on and no outs in the eighth, Bochy sent Gorkys Hernandez up to bunt. Hernandez couldn’t get one down and instead flied out. Two batters later, the Rockies were out of the inning with their one-run lead intact, and they held on for a 6-5 win at Coors Field, a place where execution isn’t often talked about, but still matters the same.&nbsp;</p>
<p>The Giants lost a one-run game for the sixth time this season. Bochy knows what the issue is.</p>
<p>“If you look at them there’s something where you didn’t execute,” he said. “It probably caught up with us, not getting the bunt down.”</p>
<p>The rhythm of an inning changes when there are runners on second and third instead of first and second, but it’s not hard to imagine the Giants getting that tying run home. Denard Span came up next and flied out to deep center, but there was no runner on third to jog home.&nbsp;</p>
<p>“We’re having a tough time scoring runs,” Bochy said. “We’ve got to execute and do the little things.”</p>
<p>In a park that plays&nbsp;small, the Giants paid for several mistakes. The one that put them behind came on defense. Cueto had already given up a grand slam in the fourth and put another runner on when Charlie Blackmon hit a two-out liner to right. Pence chased it but lost it in the lights, falling awkwardly as the ball shot to the outfield wall. Pence got up and limped after the ball as Blackmon raced home for an inside-the-park homer.&nbsp;</p>
<p>“It was in the lights the whole time,” Pence said. “There are a lot of balls in the lights and you’ve got to fight your way through it, and I wasn’t able to do that.”</p>
<p>To add injury to insult, Pence twisted his left knee as he went down. He paced around in right and then showed a slight limp when the inning was over. When he got back to the dugout, Pence was checked by trainer Dave Groeschner. He appeared to be fine the rest of the game.&nbsp;</p>
<p>“It feels alright,” he said. “For now, I’m pretty sure it’s fine.”</p>
<p>After speaking to reporters, Pence went off to the training room for a second check-up. He was confident that the knee wouldn’t be an issue, and the Giants could certainly use the good news. In the last week, they’ve lost Jarrett Parker and Madison Bumgarner for extended periods. Bochy missed two games this week after a minor heart procedure.&nbsp;</p>
<p>“You keep doing what you’re doing,” Cueto said. “We’re playing very hard and trying to win every game. Eventually we’re going to find a way to win games.”</p>
<iframe style="border: none; margin:0px; width:100%; height:250px;" src="https://www.stanza.co/@mlb-giants?embed=true&banner=true&site=comcastsportsnet"></iframe> 
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/alex-pavlovic" rel="tag">Alex Pavlovic</a>, <a href="/tags/bruce-bochy" rel="tag">Bruce Bochy</a>, <a href="/tags/hunter-pence" rel="tag">Hunter Pence</a>, <a href="/tags/johnny-cueto" rel="tag">Johnny Cueto</a>, <a href="/tags/mlb" rel="tag">MLB</a>, <a href="/tags/san-francisco-giants" rel="tag">San Francisco Giants</a></span>
        <div class="comments-container">
              <div id="respond-213326">
          <div id="213326" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-213326"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-213326"></div>
    <div id="taboola-container-text-links-post-213326"></div>
  </footer>
  <!-- .entry-footer -->
</article>

<article id="post-213311" class="article-module nbcs-article">
    <div class="article-midbanner" id="midbanner-213311"></div>
  <span id='chrome-data-post-213311' class="hidden" data-chrome='{"league":"mlb","sport":"baseball","sponsor":"alexpavlovic"}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Instant Replay: Giants' offense comes alive, but Cueto allows six to Rockies    </h2>
          <div class="article-chromedheader"></div>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-213311"
         href="http://www.csnbayarea.com/video/drive-game-flashback-pences-457-foot-blast-coors-field"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/bayarea_article/select/media/Il4d80u3wD2v?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/42117gdrive.jpg?itok=U0-qJOWI" width="656" height="369" alt="42117gdrive.jpg" title="Drive of the Game: Flashback to Pence&#039;s 457-foot blast at Coors Field" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Instant Replay: Giants' offense comes alive, but Cueto allows six to Rockies    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/alex-pavlovic">Alex Pavlovic</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnbayarea.com/giants/instant-replay-giants-offense-comes-alive-cueto-allows-six-rockies"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">April 21, 2017 8:30 PM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-213311" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-213311" id="comments-link-213311" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-213311">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
          </div>
    <p><a href="http://stats.csnbayarea.com/mlb/boxscore.asp?gamecode=370421127"><strong>BOX SCORE</strong></a></p>
<p>DENVER — A day after the Giants lost their left-handed ace, their right-handed ace took his first loss of the season.&nbsp;</p>
<p>Johnny Cueto gave up a six-spot in the fourth and the Giants never quite bounced back, losing 6-5 to the Rockies. They have lost two of three to kick off the road trip and dropped to 6-11 on the season, five games behind the first place Rockies.&nbsp;</p>
<p>Early on, it looked like Cueto would make the Giants temporarily forget about the pain of Madison Bumgarner’s injury. Cueto opened with three scoreless frames and the lineup batted around in the second, getting four singles and an RBI double from Eduardo Nuñez.&nbsp;</p>
<p>It all fell apart in the fourth.&nbsp;</p>
<p>Cueto gave up five straight hits, including a Trevor Story grand slam on a ball that got up in the thin air and kept carrying out to right. Story became the first player to hit a grand slam off Cueto in the big leagues. Two batters later, Charlie Blackmon added an inside-the-park dinger. Blackmon hit a two-out liner to right and Hunter Pence lost it in the lights, slipping as he held his arms up. Blackmon raced all the way home, sliding in just ahead of a relay throw to give the Rockies a six-run inning. The Rockies became the first National League team since 1950 to hit a grand slam and inside-the-parker in the same inning.&nbsp;</p>
<p>In the bottom of seventh and top of eighth, both teams missed out. The Rockies loaded the bases with two outs when Cory Gearrin walked two and hit one, but Story popped out. In the next half-inning, Joe Panik drove a run in but the Giants couldn’t get him in from second with no outs. Gorkys Hernandez failed to get a bunt down and then flied out. Denard Span flied out to center. Belt popped up to third.&nbsp;</p>
<p><strong>Starting pitching report:</strong><strong> </strong>Before Story knocked one over the out-of-town scoreboard, Cueto had faced 146 hitters with the bases loaded without allowing a homer. He had actually been very efficient in the worst situation, holding opposing hitters to a .167/.247/.230 slash line.</p>
<p><strong>Bullpen report: </strong>Ty Blach made what might be his final relief appearance for months. He retired all three batters he faced in the sixth. He'll start Tuesday.&nbsp;</p>
<p><strong>At the plate:</strong> Belt’s homer went 456 feet, according to Statcast. His three longest homers have all come at Coors Field: 475 feet, 457 and 456.&nbsp;</p>
<p><strong>In the field:</strong> Panik gave a reminder of why he’s the reigning Gold Glove winner. He made a leaping catch of DJ LeMahieu’s liner in the third and a diving stop to rob Blackmon in the sixth.&nbsp;</p>
<p><strong>Attendance: </strong>The Rockies didn’t announce a number, but a bunch of gamers stuck it out through the 40-degree weather and relentless drizzle.&nbsp;</p>
<p><strong>Up next: </strong>Matt Moore makes his second Coors Field appearance as a Giant. The first one: 2 2/3 innings, six earned runs.&nbsp;</p>
<iframe style="border: none; margin:0px; width:100%; height:250px;" src="https://www.stanza.co/@mlb-giants?embed=true&banner=true&site=comcastsportsnet"></iframe> 
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/alex-pavlovic" rel="tag">Alex Pavlovic</a>, <a href="/tags/brandon-belt" rel="tag">Brandon Belt</a>, <a href="/tags/johnny-cueto" rel="tag">Johnny Cueto</a>, <a href="/tags/mlb" rel="tag">MLB</a>, <a href="/tags/san-francisco-giants" rel="tag">San Francisco Giants</a></span>
        <div class="comments-container">
              <div id="respond-213311">
          <div id="213311" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-213311"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-213311"></div>
    <div id="taboola-container-text-links-post-213311"></div>
  </footer>
  <!-- .entry-footer -->
</article>
  </div>
  <div id="article-loadmore">
    <div class="footer_more-link">
      <a href="/articles/6/201/1" id="load_more_articles" class="use-ajax link link_type-block">Load more</a>    </div>
  </div>
</div>
  </div>
</div>
  </div>
                </div>
            </div>

                        <aside id="nbcsports-right-rail" class="sidebar sidebar_second">
                <div class="region region-right-rail">
    <div id="block-nbcs-article-nbcs-article-rail" class="block block-nbcs-article">

    
  <div class="content">
    <div id="story-explorer-wrapper">
 <aside id="story-explorer" class="styled-scrollbar">
    <div id="story-explorer-headlines">
      <div id="article-rail-ad"></div>
       <div id="article-rail-ad"></div>

<a href="/giants/ball-lost-lights-failure-execute-late-haunt-giants-loss-rockies" class="story-explorer-item" id="headline-213326">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/blackmon-hr-ap.jpg?itok=BAespQRu" width="656" height="369" alt="blackmon-hr-ap.jpg" title="Ball lost in lights, failure to execute late haunt Giants in loss to Rockies" /></span>
  <span class="item-headline">Ball lost in lights, failure to execute late haunt Giants in loss to Rockies</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492835695"></span>
</a>

<a href="/giants/instant-replay-giants-offense-comes-alive-cueto-allows-six-rockies" class="story-explorer-item" id="headline-213311">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/giants-ir-us.jpg?itok=cZA5j33P" width="656" height="369" alt="giants-ir-us.jpg" title="Instant Replay: Giants&#039; offense comes alive, but Cueto allows six to Rockies" /></span>
  <span class="item-headline">Instant Replay: Giants' offense comes alive, but Cueto allows six to Rockies</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492832461"></span>
</a>

<a href="/giants/giants-upton-jr-undergoes-surgery-torn-thumb-ligament" class="story-explorer-item" id="headline-213286">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/upton-ap.jpg?itok=e8wKPNsY" width="656" height="369" alt="upton-ap.jpg" title="Giants OF Upton Jr. undergoes surgery on torn thumb ligament" /></span>
  <span class="item-headline">Giants OF Upton Jr. undergoes surgery on torn thumb ligament</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492825562"></span>
</a>

<a href="/giants/giants-notes-bochy-returns-ready-roll-after-minor-heart-procedure" class="story-explorer-item" id="headline-213231">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/bochy-blach-us.jpg?itok=2E6G8tJd" width="656" height="369" alt="bochy-blach-us.jpg" title="Giants notes: Bochy returns, &#039;ready to roll&#039; after minor heart procedure" /></span>
  <span class="item-headline">Giants notes: Bochy returns, 'ready to roll' after minor heart procedure</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492819144"></span>
</a>

<a href="/giants/giants-team-bus-backs-car-way-coors-field" class="story-explorer-item" id="headline-213191">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/bochy-ap.jpg?itok=BXWssIDM" width="656" height="369" alt="bochy-ap.jpg" title="Giants&#039; team bus backs into car on the way to Coors Field" /></span>
  <span class="item-headline">Giants' team bus backs into car on the way to Coors Field</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492815740"></span>
</a>

<a href="/giants/giants-lineup-span-back-center-leading-vs-rockies" class="story-explorer-item" id="headline-213171">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/span-giants-us.jpg?itok=nx0QMcZV" width="656" height="369" alt="span-giants-us.jpg" title="Giants lineup: Span back in center, leading off vs Rockies" /></span>
  <span class="item-headline">Giants lineup: Span back in center, leading off vs Rockies</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492813999"></span>
</a>

<a href="/giants/bumgarner-dl-biggest-gut-punches-giants" class="story-explorer-item" id="headline-213151">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/giants-bumgarner-ray.jpg?itok=Vyz92oRh" width="656" height="369" alt="giants-bumgarner-ray.jpg" title="Bumgarner on the DL is the biggest of gut punches for Giants" /></span>
  <span class="item-headline">Bumgarner on the DL is the biggest of gut punches for Giants</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492810892"></span>
</a>

<a href="/giants/giants-place-madison-bumgarner-disabled-list-after-dirt-bike-accident" class="story-explorer-item" id="headline-213136">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/madison-disabled-list_1.jpg?itok=t28JuA_l" width="656" height="369" alt="madison-disabled-list.jpg" title="Giants place Madison Bumgarner on disabled list after dirt bike accident" /></span>
  <span class="item-headline">Giants place Madison Bumgarner on disabled list after dirt bike accident</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492807482"></span>
</a>

<a href="/giants/down-farm-arroyos-hit-streak-ends-still-leads-triple-batting-average" class="story-explorer-item" id="headline-213121">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/21/arroyo_1.jpg?itok=i4ntfyX5" width="656" height="369" alt="arroyo_1.jpg" title="Down on the Farm: Arroyo&#039;s hit streak ends, still leads Triple-A in batting average" /></span>
  <span class="item-headline">Down on the Farm: Arroyo's hit streak ends, still leads Triple-A in batting average</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492805606"></span>
</a>

<a href="/giants/what-theyre-saying-happy-birthday-brandon-belt" class="story-explorer-item" id="headline-212961">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/20/belt-birthday-us.jpg?itok=5whV0TR_" width="656" height="369" alt="belt-birthday-us.jpg" title="What they’re saying: Happy birthday Brandon Belt" /></span>
  <span class="item-headline">What they’re saying: Happy birthday Brandon Belt</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492756476"></span>
</a>

<a href="/giants/giants-continue-april-trend-fail-give-bumgarner-any-run-support" class="story-explorer-item" id="headline-212481">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/19/giants-colum-us.jpg?itok=VrZasP4c" width="656" height="369" alt="giants-colum-us.jpg" title="Giants continue April trend, fail to give Bumgarner any run support" /></span>
  <span class="item-headline">Giants continue April trend, fail to give Bumgarner any run support</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492659279"></span>
</a>

<a href="/giants/instant-replay-royals-finally-score-bumgarner-giants-shut-out" class="story-explorer-item" id="headline-212441">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/19/giants-ir-us.jpg?itok=PlY0bJIi" width="656" height="369" alt="giants-ir-us.jpg" title="Instant Replay: Royals finally score off Bumgarner, Giants shut out" /></span>
  <span class="item-headline">Instant Replay: Royals finally score off Bumgarner, Giants shut out</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492656211"></span>
</a>

<a href="/giants/return-kc-bumgarner-will-face-hitter-he-first-met-17-years-ago" class="story-explorer-item" id="headline-212346">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/19/merrifield-bumgarner-usatsi.jpg?itok=W3bfYs6d" width="656" height="369" alt="whit.jpg" title="In return to KC, Bumgarner will face hitter he first met 17 years ago" /></span>
  <span class="item-headline">In return to KC, Bumgarner will face hitter he first met 17 years ago</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492637868"></span>
</a>

<a href="/giants/giants-lineup-span-out-hill-leading-finale-vs-royals" class="story-explorer-item" id="headline-212306">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/19/aaron-hill-belt-ap.jpg?itok=AQYiS_UH" width="656" height="369" alt="aaron-hill-belt-ap.jpg" title="Giants lineup: Span out, Hill leading off in finale vs Royals" /></span>
  <span class="item-headline">Giants lineup: Span out, Hill leading off in finale vs Royals</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492632076"></span>
</a>

<a href="/giants/down-farm-morse-plays-left-goes-hitless-first-rehab-game" class="story-explorer-item" id="headline-212291">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/19/morse-cage-ap.jpg?itok=LG62uvXl" width="656" height="369" alt="morse-cage-ap.jpg" title="Down on the Farm: Morse plays left, goes hitless in first rehab game" /></span>
  <span class="item-headline">Down on the Farm: Morse plays left, goes hitless in first rehab game</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492630485"></span>
</a>

<a href="/giants/report-angel-pagan-taking-2017-season" class="story-explorer-item" id="headline-212266">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/19/pagan-angel-salute-world0series.jpg?itok=msOYMW-x" width="656" height="369" alt="pagan-angel-salute-world0series.jpg" title="Report: Angel Pagan taking the 2017 season off" /></span>
  <span class="item-headline">Report: Angel Pagan taking the 2017 season off</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492627560"></span>
</a>

<a href="/giants/panik-finds-grass-extra-innings-leads-giants-win-return-kc" class="story-explorer-item" id="headline-212076">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/18/lorenzocain-panikhit-ap.jpg?itok=Nr4l_n1a" width="656" height="369" alt="locain.jpg" title="Panik finds grass in extra innings, leads Giants to win in return to KC" /></span>
  <span class="item-headline">Panik finds grass in extra innings, leads Giants to win in return to KC</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492577509"></span>
</a>

<a href="/giants/instant-replay-panik-delivers-big-hit-giants-beat-royals-11" class="story-explorer-item" id="headline-212026">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/18/panikhit-kc-ap.jpg?itok=wh3aw1-D" width="656" height="369" alt="panikscoring-royals-2017-ap.jpg" title="Instant Replay: Panik delivers big hit, Giants beat Royals in 11" /></span>
  <span class="item-headline">Instant Replay: Panik delivers big hit, Giants beat Royals in 11</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492574000"></span>
</a>

<a href="/giants/giants-notes-bumgarner-draws-crowd-kc-latest-posey-bochy" class="story-explorer-item" id="headline-211906">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/18/bumgarner-kc-worldseries-2014-usatsi.jpg?itok=Ny7ZzNQk" width="656" height="369" alt="bum_nats.jpg" title="Giants notes: Bumgarner draws a crowd in KC; Latest on Posey, Bochy" /></span>
  <span class="item-headline">Giants notes: Bumgarner draws a crowd in KC; Latest on Posey, Bochy</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492557143"></span>
</a>

<a href="/giants/pirates-all-star-starling-marte-hit-80-game-ped-ban" class="story-explorer-item" id="headline-211896">
  <span class="item-thumbnail"><img src="/sites/csnbayarea/files/styles/article_hero_image/public/2017/04/18/marte-pirates-ap.jpg?itok=fLzesmag" width="656" height="369" alt="marte-pirates-ap.jpg" title="Pirates All-Star OF Starling Marte hit with 80-game PED ban" /></span>
  <span class="item-headline">Pirates All-Star OF Starling Marte hit with 80-game PED ban</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1492555999"></span>
</a>
<div id="story-explorer-legal">
  </div>
    </div>
  </aside>
</div>
  </div>
</div>
  </div>
            </aside>
                      </div>

        </div>
        <!-- End main content -->

      </div>
      <!-- End content wrapper -->

      <!-- Start footer -->
      <footer id="nbcsports-footer">
          <div class="region region-footer">
    <div id="block-bean-dx-agency-facebook-pixel" class="block block-bean block-bean-custom-block block-type-custom-block block-type-custom-block-single">

    
  <div class="content">
    <div class="entity entity-bean bean-custom-block clearfix">

  <div class="content">
    <div class="field field-name-field-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '134498090361673');
fbq('track', 'PageView');
fbq('track', 'ViewContent');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=134498090361673&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code --></div></div></div>  </div>
</div>
  </div>
</div>
<div id="block-nbcs-footer-nbcs-footer" class="block block-nbcs-footer">

    
  <div class="content">
    <div id="footer-left">
  <div id="footer-logo"></div>
  <div id="footer-social-links">
    <span id="follow-us">FOLLOW US</span>
          <a href="https://www.facebook.com/NBCSAuthentic" class="genericon genericon-facebook">Facebook</a>          <a href="https://twitter.com/NBCSAuthentic/" class="genericon genericon-twitter">Twitter</a>          <a href="https://www.instagram.com/NBCSAuthentic" class="genericon genericon-instagram">Instagram</a>      </div>
  <div id="copyright">©2017 Comcast SportsNet California, LLC</div>
  <div id="footer-site-links">
          <a href="http://www.nbcuniversal.com">A Division of NBC Universal</a>          <a href="http://www.csnbayarea.com/press-releases">Press Releases</a>          <a href="http://www.csnbayarea.com/contact-us">Contact Us</a>          <a href="http://www.nbcunicareers.com/">Employment Opportunities</a>          <a href="http://www.csnbayarea.com/internship_description">Internships</a>          <a href="http://www.csnbayarea.com/terms-service">Terms of Service</a>          <a href="http://www.nbcuniversal.com/privacy">Privacy Policy</a>          <a href="http://www.csnbayarea.com/page/advertise-nbcsba">Advertising with NBCS BA</a>          <a href="http://www.csnbayarea.com/closed-captioning">Closed Captioning</a>          <a href="http://www.controlwithcable.org/">Parents Guide to TV Ratings</a>          <a href="http://corporate.comcast.com/news-information/nbcuniversal-transaction/independent-programming">Independent Programming Guide</a>          <a href="http://www.csnbayarea.com/live-faq">Live FAQ</a>          <a href="http://www.csnbayarea.com/ontv">TV Listings</a>      </div>
</div>
<div id="footer-right">
  <div id="footer-newsletter-link">
        <span id="newsletter-banner">GET NEWSLETTERS &amp; ALERTS</span>&#13;
    <a href="http://email.comcastsportsnet.com/csn/prefbay.do" id="newsletter-link">SIGN UP</a>  </div>
</div>
  </div>
</div>
  </div>
      </footer>
      <!-- End footer -->

    </div><!-- end #outer -->
  </div><!-- end #wrapper -->
  <!-- SiteCatalyst code version: 1.7.0
Copyright 1996-2017 Adobe, Inc. -->
<script type="text/javascript" src="/sites/all/modules/custom/nbcs_sitecatalyst/js/nbcs_adobe.js?oodbgd"></script>
<script type="text/javascript"><!--

var nbcscontenthub="nbcs.contenthub";
s.contextData[nbcscontenthub]="News";
var nbcsteam="nbcs.team";
s.contextData[nbcsteam]="Giants";
var nbcsleague="nbcs.league";
s.contextData[nbcsleague]="MLB";
var nbcssport="nbcs.sport";
s.contextData[nbcssport]="Baseball";
var nbcsauthor="nbcs.author";
s.contextData[nbcsauthor]="NBC Sports Bay Area staff";
var nbcssubfeature="nbcs.subfeature";
s.contextData[nbcssubfeature]="Giants";
var nbcscontenttype="nbcs.contenttype";
s.contextData[nbcscontenttype]="Story";
var nbcscontentid="nbcs.contentid";
s.contextData[nbcscontentid]="213286";
var nbcscontenttitle="nbcs.contenttitle";
s.contextData[nbcscontenttitle]="Giants OF Upton Jr. undergoes surgery on torn thumb ligament";
var nbcspagenumber="nbcs.pagenumber";
s.contextData[nbcspagenumber]=1;
var nbcsrelease_version="nbcs.release_version";
s.contextData[nbcsrelease_version]="1.26.1";
/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
var s_code=s.t();if(s_code)document.write(s_code)//--></script>
<script type="text/javascript"><!--
if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')
//--></script>
<noscript><img src="http://examplecom.112.2O7.net/b/ss/examplecom/1/H.20.3--NS/0/3976972" height="1" width="1" alt=""></noscript>
<!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: 1.7.0 -->
<script type="text/javascript" src="//www.csnbayarea.com/sites/csnbayarea/files/advagg_js/js__lOCAh6_G2-syfSonbl_eRlz9mAnNDG7xohglRBwEoSo__GS5ds9kzIoBH1l_hrriHCM_VLQv5drEonElm4bMePaA__komvlXmZGg8elenQgR5sS9hUCIJgx84es8yukR25qJs.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
typeof(mps)=='object' && typeof(mps.writeFooter)=='function' && mps.writeFooter();
//--><!]]>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"cf07660617","applicationID":"15907363","transactionName":"ZQNbZ0cAX0UEABdcCVxJeFBBCF5YSg0MUQNtFlhUUD5HXwAU","queueTime":0,"applicationTime":706,"atts":"SURYEQ8aTEs=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
